Problem with my new detector a xt 18000

Go down

Problem with my new detector a xt 18000 Empty Problem with my new detector a xt 18000

Post  wombatroo on Tue Apr 10, 2012 7:26 pm

Hi new to the forum. I purchased a xt 18000 off ebay and it worked great the first couple of times at the beach. I found a gold ring Very Happy I am now having problems with it. I am sure its the cord from the coil to the box. When I wiggle it it makes the oveload sound. I have cleaned the end that goes into the box but its still doing it. I was wondering if there is anything I can do. It looks like the cord is attached to the coil and cant be removed. Or maybe someone know someone in the Frankston area that repairs I have heard there is someone. So disappointing had my first big trip planned to Talbot Friday not looking to good tonight Sad
wombatroo
wombatroo
Contributor Plus
Contributor Plus

Number of posts : 200
Registration date : 2012-04-07

Back to top Go down

Problem with my new detector a xt 18000 Empty Re-problem-with-my-new-detector-a-xt-18000

Post  Guest on Tue Apr 10, 2012 7:40 pm

Gday Wombatroo there is a bloke who dose detector mods in Frankston STH Woody Link Technologies
WWW.detectormods.com PH (03) 90175549 Hope this helps.

Cheers.

Mike. cheers

Guest
Guest


Back to top Go down

Problem with my new detector a xt 18000 Empty Re: Problem with my new detector a xt 18000

Post  wombatroo on Tue Apr 10, 2012 7:43 pm

Thanks so much Mike I will give him a call.
wombatroo
wombatroo
Contributor Plus
Contributor Plus

Number of posts : 200
Registration date : 2012-04-07

Back to top Go down

Problem with my new detector a xt 18000 Empty 18000 repair

Post  goldsucker on Fri May 11, 2012 7:21 pm

Send the box and coil to Gympie Detectors and they will repair and return it. gympiedetectors.com.au regards Tim

goldsucker
New Poster
New Poster

Number of posts : 7
Registration date : 2012-03-20

Back to top Go down

Problem with my new detector a xt 18000 Empty xt18000

Post  wombatroo on Sun May 27, 2012 11:04 pm

Thanks goldsucker.
Took it to Laanecoorie this weekend after having the coil cord repaired a couple of times, but after having Wombat and Big Tom play around with it, it just kept going off all the time, Big Tom told me it just picking up lots of gold:) I am going to replace the coil and see how it goes. Will post a wanted ad tomorrow.
wombatroo
wombatroo
Contributor Plus
Contributor Plus

Number of posts : 200
Registration date : 2012-04-07

Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum